Beyond Hollywood - das Filmsyndikat

Schwarzes Brett => News => Thema gestartet von: Bloodsurfer am 26. Juli 2013, 18:20:46

Titel: ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 26. Juli 2013, 18:20:46
Ich muss das Posting leider etwas knapp halten, da ich gleich noch zu einem Termin muss. Ihr erinnert euch noch an http://beyondhollywood.de/index.php/topic,18397.0.html - oder? Es standen noch ein paar Updates aus, die ich nun sehr dringend machen muss.

Habe heute eine Warnungs-Mail bekommen, dass eine der Adressen, unter der dieser Server erreichbar ist, als Phishing-Site gemeldet wurde. Leider hat sich das nach genauer Betrachtung auch bestätigt - es wurde ein Skript hinterlegt, welches zu einer Phishing-Site weiterleitete.

Alles, was ich gefunden habe, habe ich natürlich sofort unschädlich gemacht bzw. verschoben und gesichert etc.

Daher laufen aktuell nicht mehr alle Dienste - d.h. zum Beispiel, dass der Server aktuell KEINE MAILS senden darf. Ihr werdet also keine Benachrichtigungen über neue PNs oder ähnliches in der nächsten Zeit bekommen. Im Grunde ist nur noch das Forum selbst online, weil ich hier keinen Verdacht auf Manipulationen/Schwachstellen habe.

Über die Ursache kann ich aktuell nur teilweise Auskunft geben bzw. spekulieren - meine Freundin hat gestern ihren Blog aktualisiert und weil das Update nicht auf Anhieb funktioniert hat, dabei einen kleinen Fehler gemacht. Sprich, sie hat zu viele Schreibrechte freigegeben. Daher war auch bisher nur ihre URL von der Phishing-Meldung betroffen. Das allein ist aber nicht das ganze Problem, irgendwo muss noch eine Lücke sein. Ich tippe auf die Wordpress-Software oder das OS selbst, da ich wie in obigem Link angegeben leider schon eine ganze Latte an Updates sträflich vernachlässigt habe. Das rächt sich nun natürlich.

Zum weiteren Vorgehen: Ich werde in den nächsten Tagen, vermutlich im Raum Samstag-Dienstag, sofort alle nötigen Updates aufspielen und weitere Beweise suchen/sichern. In dieser Zeit ist das Forum dann voraussichtlich nicht erreichbar.

Im Worst Case, falls wirklich ein Rootkit oder ähnlich installiert worden sein sollte, müsste ich den Server komplett platt machen und neu aufsetzen. Das würde natürlich eine Weile dauern. Ich gehe davon jedoch zumindest aktuell nicht aus, also vorerst noch keine Sorge.

Sobald ich genaueres weiß, werde ich mich wieder melden. Das Forum wird auch garantiert wieder online gehen, selbst im schlimmsten Fall wird es nur ein paar Tage länger dauern ;)
Zumindest ist es ein gutes Zeichen, dass bisher nur eine URL betroffen ist. Daher gehe ich von einem eher kleineren "Schaden" aus.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: JasonXtreme am 26. Juli 2013, 18:28:26
Uff beftige nummer! Ich hoff es is nur halb so schlimm!
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 26. Juli 2013, 18:58:40
Hossa  :shock:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: skfreak am 26. Juli 2013, 19:26:48
Kacke, Andi. Phising hatten wir auch mal bei uns auf'm Server gehabt. War damals mal wieder ein phpBB-Hack :(
Drück dir die Daumen das alles soweit klappt.

BLÖDE FRAGE: Könntest du nicht mal eine beyondholllywood-Seite bei FB machen und über den Stand informieren?
Bei einem anderen Forum haben die Admins das auch gemacht um dort mal berichten zu können falls das Forum down ist. Die meisten sind da ja und falls es länger dauert kann man so die meisten hier zentral informieren :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 26. Juli 2013, 19:38:35
Phising hatten wir auch mal bei uns auf'm Server gehabt. War damals mal wieder ein phpBB-Hack :(
Tja, meistens ist es eine Lücke in der Software. Hier kam wohl ein Wordpress-Problem mit Sarahs Fehler zusammen, zu viele Rechte freizugeben.

BLÖDE FRAGE: Könntest du nicht mal eine beyondholllywood-Seite bei FB machen und über den Stand informieren?
Bei einem anderen Forum haben die Admins das auch gemacht um dort mal berichten zu können falls das Forum down ist. Die meisten sind da ja und falls es länger dauert kann man so die meisten hier zentral informieren :)
Über eine FB-Seite hatten wir uns hier sogar schon mal unterhalten (oder sogar abgestimmt? weiß es nimmer so genau). Glaube aber leider, die meisten waren dagegen.

Selbst ohne eine Seite eigens für das Forum einzurichten könnte ich kurzfristig auf meiner eigenen FB- oder Twitterseite informieren, kommt im Grunde auf das Gleiche raus.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: JasonXtreme am 26. Juli 2013, 19:45:30
Fb gruppen kann man ja auch sperren für andere user ;)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Havoc am 27. Juli 2013, 09:54:08
Ärgerlich, kann aber leider passieren.  :|
Ein paar Tage Ausfalle kann man verkraften.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 04. August 2013, 22:52:43
Mit der Spurensuche bin ich erstmal durch. Ich denke, dass ich ab Morgen mit dem großen Update loslegen werde. Das wird mich ziemlich sicher mindestens den ganzen Tag lang beschäftigen.

Für die Zeit, in der das Forum offline sein sollte, werde ich euch natürlich hier mit aktuellen Updates versorgen:
https://twitter.com/bloodsurfer
Da sollte jeder mitlesen können, auch ohne selbst bei Twitter angemeldet zu sein. (Falls das falsch sein sollte, kurz Laut geben!)

Hoffe, das schnell und problemlos abwickeln zu können.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 05. August 2013, 12:39:00
Letzte Warnung: Ich frühstücke jetzt noch gemütlich, danach nehme ich euch für ein paar Stunden das Form weg! :D
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Max_Cherry am 05. August 2013, 13:17:18
Schon mal Danke für den Arsch voll Arbeit, der auf dich zu kommt.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Ash am 05. August 2013, 13:57:48
Frohes Schaffen!
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 01:18:28
Ahoi. Kurzer Bericht.

Zuerst die gute Nachricht. Die Server-Upgrades an sich liefen schnell und schmerzfrei ab. Ich habe Debian von "Lenny" zuerst auf "Squeeze" und danach von "Squeeze" auf "Wheezy" aktualisiert, ohne dass es zu größeren Problemen gekommen ist. Besonders, dass die erste Hälfte so leicht ging, hat mich ein wenig verwundert, da ich aufgrund der Umstellung auf udev und neue Kernel-Versionen schon eher mit Schwierigkeiten gerechnet habe. Ging jedoch wirklich schmerzfrei und die Maschine war nach jedem Reboot sofort wieder über das Netzwerk erreichbar, was mich auch positiv überrascht hat.

Da sieht man mal wieder, dass Debian sich als Server-OS wirklich lohnt - sehr pflegeleicht und wirklich gut dokumentiert.

Der Server lief nun also fehlerfrei auf Wheezy - Zeit, noch "schnell" das Forum selbst von 2.0rc4 auf 2.0.4 zu aktualisieren, was ich auch viel zu lange aufgeschoben habe. Nun zur schlechten Nachricht. Hier gingen die Scheißprobleme los. Unglaublich, wie störrisch die "automatische" Datenbank-Konvertierung ist...

Fragt mich nicht nach Details, ich musste an allen Ecken und Enden wie PHP-Prozesslimits, MySQL-Einstellungen und anderen Dingen schrauben und diverse Scripts von Hand abändern und es immer und immer wieder ausprobieren, bis irgendwann SECHS VERDAMMTE STUNDEN SPÄTER das Ding bis zum Schluss durchgelaufen ist. Das allein hat länger gedauert als die beiden kompletten Debian-Riesenupdates vorher zusammen. Und jetzt bin ich mir nicht mal sicher, ob die Datenbank überhaupt noch konsistent ist.

Wenn ich mir die Startseite so anschaue, da ist z.B. schon die Reihenfolge der Boards völlig durcheinander geraten. Kann mir kaum vorstellen, dass das die einzige seltsame Erscheinung sein soll. Das könnte ich mir allerdings zumindest noch verständlich erklären aufgrund der abgelaufenen Scripte... Hier bräuchte ich eure Mithilfe... Probiert mal aus, ob sich das Forum für eure Gewohnheiten "normal" verhält. Meldet euch, sobald irgend etwas auffällt. Ich persönlich werfe auch ein Auge darauf und schaue regelmäßig auf die internen Logs, ob mir dort Unregelmäßigkeiten begegnen.

Falls jetzt wirklich noch ein größeres Problem mit der Datenbank bestehen sollte, müsste ich wieder auf das letzte Backup zurück springen. Problem dabei wäre natürlich, dass sämtliche Postings, die seit dem letzten Backup (heute früh um vier Uhr) geschrieben wurden, dabei gelöscht würden. Unschön, aber noch nicht das größte Problem. Denn nach der Wiederherstellung aus einem Backup müsste ich die Datenbank natürlich erneut konvertieren, was mich wieder an den Anfang werfen würde... Teufelskreis.

Zumindest die Wartungsfunktionen/Routine-Checks im Forum behaupten, es wäre jetzt alles OK. Das wäre aber fast zu schön, um wahr zu sein. Ich drücke beide Daumen und hoffe, dass es nicht zu weiteren Problemen oder Fehlern kommt und wenn, dass ich diese irgendwie fixen kann ohne ein Backup einspielen zu müssen...
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Max_Cherry am 06. August 2013, 01:46:16
Danke für die umfangreiche Arbeit!
Ich werd versuchen, auf Unterschiede zu achten.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 01:48:43
Oh oh, großes Problem! Das Spoiler-Mod ist mit der aktuellen SMF-Version nicht mehr kompatibel. Alle Spoiler stehen gerade im Klartext hier.

Seid vorsichtig beim Lesen in Film-relevanten Themen... Ich suche nach einer Alternative.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: dead man am 06. August 2013, 03:28:18
Danke fuer die Arbeiten!

Ausser das die Boards anders angeordnet sind steht bei mir bei den "ungelesen Beitraegen" jetzt hinter jedem Beitrag "neuer Beitrag". War vorher nicht da.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 07:41:58
Zumimdest der Bilderupload scheint irgendwie weg zu sein.

Die Foren kann ich heute Abend sortieren.

Hoffentlich haben sich keine Berechtigungen oder so verändert.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Havoc am 06. August 2013, 07:44:43
Der Link zum Bilderupload (oberhalb von "Ungelesene Beiträge seit...") ist nicht mehr vorhanden.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Nation-on-Fire am 06. August 2013, 07:54:02
Sieht im Moment etwas unsortiert aus, aber kein Problem, umso mehr muss man sich mit der Materie beschäftigen.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 08:05:03
Beim "klassischen" Theme ist er noch da. Funktioniert bloß nicht bzw. führt ins Nichts.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 08:18:29
Okay, gerade mal in den Adminbereich geschaut. Dort haben die Boards die richtige Reihenfolge... What the...? :confused:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Flightcrank am 06. August 2013, 16:47:54
Oha, alles recht ungeordnet hier!  :uglylol:

Aber der Andi macht das schon! ;) Danke schon mal bis dahin!  :thumb: :thumb: :thumb:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 18:28:27
Ihr glaubt gar nicht wie froh ich bin, dass überhaupt noch irgendwas läuft nach der gestrigen Abend-/Nachtsession! :uglylol:

- OK, der Bilderupload ist tot. Interner Serverfehler. Muss ich in den Code schauen, da hat sich vermutlich etwas an den Funktionen geändert, die seitens SMF bereitgestellt werden und die ich genutzt habe. Kann aber auch nichts großes sein, die Logs werden Aufschluss geben.
@Pierre: Den Link zum Upload sehe ich allerdings auch im dunklen Theme noch. Wieso ist er bei dir verschwunden? :confused:

- Die Boardreihenfolge ist so eine Sache... Kann mich dunkel erinnern, dass eines der DB-Scripte etwas umsortiert hat. Das muss ich auf SQL-Ebene von Hand wieder gerade biegen. Muss ich mich schlau machen, das ist aber glaube ich auch das kleinste Problem aktuell :D

- Spoilermod. Ich suche eine Alternative oder implementiere notfalls die gewohnte Funktionalität selbst. Das ist keine sooo große Sache.

- Die "Neue Beiträge"-Bildchen sind nun rechts neben dem Titel jedes Threads anstatt links davon. Das kommt dadurch, dass ich das Default-Theme beim Update überschreiben musste. Das dunkle Theme übernimmt einen Großteil vom Code des Standard-Themes, es überschreibt nur den Teil, den es unbedingt ändern muss. An die Änderung kann ich mich noch erinnern bzw. hatte ich mir damals notiert, das biege ich schnell wieder gerade.

Möge der Spaß beginnen :D
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Max_Cherry am 06. August 2013, 18:40:04
@Pierre: Den Link zum Upload sehe ich allerdings auch im dunklen Theme noch. Wieso ist er bei dir verschwunden? :confused:
Den Knopf/Link hab ich im "ModernDark64" auch.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 19:23:27
Beim "klassischen" Theme ist er noch da. Funktioniert bloß nicht bzw. führt ins Nichts.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 21:02:37
So scheint's wieder zu passen.


Ach ja, btw: Danke für all die Mühe, Andi  :biggrin:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 21:35:45
- Die Boardreihenfolge ist so eine Sache... Kann mich dunkel erinnern, dass eines der DB-Scripte etwas umsortiert hat. Das muss ich auf SQL-Ebene von Hand wieder gerade biegen. Muss ich mich schlau machen, das ist aber glaube ich auch das kleinste Problem aktuell :D

Dachte erst, das wäre vielleicht Andi gewesen... Aber nach kurzer Rücksprache mit ihm ist es wohl tatsächlich so, dass ich es aus dem Bauch heraus selbst hingekriegt habe. Cool  :D
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 21:57:46
OK, noch eine Kleinigkeit, auf die mich jerry aufmerksam machte: Das Texteingabefeld für neue Postings (oder das Bearbeiten alter Postings)  ist vieeeeeeeeeel zu breit. Muss ich kleiner drehen... Bzw. sollte sich das der Fenstergröße anpassen.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 22:11:15
Der Upload geht wieder. War nur eine Kleinigkeit. Habe an einer Stelle damals noch "call time pass by reference" angewendet, was von der aktuellen PHP-Version nicht mehr akzeptiert wurde. War sehr einfach zu fixen.

Das war damals, wenn ich mich richtig erinnere, mein erstes PHP-Script... Sieht aus heutiger Sicht nicht mehr so schön aus, aber ich habe schon weit schlimmeren Spaghetticode in den letzten Jahren gesehen :D
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Sing-Lung am 06. August 2013, 22:13:20
Danke für Deine Mühen!! :biggrin:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Crash_Kid_One am 06. August 2013, 22:14:30
Danke für Deine Mühen!! :biggrin:

+1
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 22:17:13
Der Upload geht wieder.

Sehr schön, den brauch ich nämlich gerade  :thumb:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 06. August 2013, 23:33:33
Bisher fiel mir nichts "Seltsames" auf im Forum. Ausser das bereits erwähnte Eingabefeld und die fehlenden Tags.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 06. August 2013, 23:41:36
Auch die Spoiler spoilern wieder. :)

(click to show/hide)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Max_Cherry am 07. August 2013, 00:10:58
Der Upload geht wieder.
Auch die Spoiler spoilern wieder. :)

(click to show/hide)

Stark!!!

Ansonsten ist mir auch nichts aufgefallen.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 07. August 2013, 00:19:26
Weiter geht's: Die Links zum Bilder-Upload und ALLEN ungelesenen Beiträgen sind nun auch im hellen Theme wieder verfügbar.

Jetzt nehme ich mir die "Neue Beiträge"-Bildchen vor...
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 07. August 2013, 02:44:57
Jetzt nehme ich mir die "Neue Beiträge"-Bildchen vor...

Done... Wieder durch das alte Bildchen ersetzt und auf die linke Seite geschoben. War eine schwere Geburt, da sich gerade hier viel im Code geändert hatte...
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 07. August 2013, 02:47:22
Btw... Da ich wegen der Bastlerei "kurz" auf das helle Standardtheme umgeschaltet hatte, habe ich mich fast wieder an selbiges gewöhnt... Die Farben gefallen mir gerade wieder recht gut, nur der Header ist scheiße. Die Transparenz wirkt auf dem hellen Grund falsch und es ist einen Tick zu hoch... Das müsste ich auch mal irgendwann verfeinern.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: JasonXtreme am 07. August 2013, 08:23:53
Alter Schwede!!! Da steckte ja doch ein ganzer Arsch voll Arbeit dahinter! Dicksten Dank Andi!!!!
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: EvilEd84 am 07. August 2013, 21:25:36
Alter Schwede!!! Da steckte ja doch ein ganzer Arsch voll Arbeit dahinter! Dicksten Dank Andi!!!!

Unterschreibe ich mal!
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: ap am 07. August 2013, 23:51:26
man man... gestern hab ich mich noch gewundert, heute lese ich das... klingt nach viel Zeit und arbeit, ja, auch von mir einfach mal ein dankeschön dafür! :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Thomas Covenant am 08. August 2013, 07:54:55
Good Job Bloody  :thumb:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Havoc am 08. August 2013, 07:56:55
Vielen Dank für die tolle Arbeit. :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 08. August 2013, 07:57:48
Mach' ich doch gerne, Freunde. Zur Zeit hab ich ja wenigstens Urlaub und kann mich um ein wenig kümmern.

Die Sache mit den überlangen Texteingabefeldern (beim Schreiben neuer Postings und beim Bearbeiten) habe ich jetzt auch gefunden und behoben, sollte wieder aussehen wie vorher. Klappt zumindest bei mir mit Standardbrowser - falls es bei jemandem noch klemmt, bitte melden!
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Sing-Lung am 08. August 2013, 21:41:34
Ich finde irgendwie die neuen Smileys doof! Gehts nur mir so? :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 09. August 2013, 12:25:25
Ups. Es sind nur versehentlich ein paar Smilies ausgetauscht worden, jedoch nicht alle. Kommt auf die Liste.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Masterboy am 09. August 2013, 14:04:25
Hey Andi,

ich habe noch folgendes Problem. Tritt mit IE auf.

(http://upload.beyondhollywood.de/images/1376049842_2013-08-09_14_03_05-Antworten.jpg)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 09. August 2013, 14:11:06
Shit. Das kommt durch die Änderung, die ich vorgenommen habe, um das überbreite Feld in allen anderen Browsern zu beseitigen.

Problem: Die eigentlich korrekte Breite des Eingabefeldes (ausgerichtet an der Fensterbreite) wird durch CSS vorgegeben. Deswegen habe ich die "Cols"-Breite der Textarea auf 0 gesetzt - so halten sich alle Browser bis auf den fucking IE an die durch CSS festgelegte Wunschbreite, die sich korrekt dem Fenster anpasst.

Ich muss für den IE wohl eine feste Spaltenzahl als Breite vorgeben. Die ignoriert dann aber vollkommen die Fenstergröße. Müssen uns also auf eine Breite einigen/festlegen, die für alle möglichen Fenstergrößen einigermaßen passt. 80 Zeichen Breite könnten für einige Konfigurationen schon zu viel sein, ist für ein großes Fenster schon zu schmal. Was schlägst du als Breite vor?

Einen Gefallen könntest du mir noch tun: Schalte mal auf das helle default Theme um und sag mir Bescheid, ob sich der IE dort mit der aktuellen Config genauso oder anders verhält. Mit etwas Glück sieht es dort vielleicht besser aus.

Und: Wie sieht das Schnellantwort-Feld unten unter jedem Thread bei dir aus?
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Masterboy am 09. August 2013, 14:18:22
Schnellantwort sieht normal aus.

Feld ist im hellen Design aber auch klein.

Was die Breit angeht weiß ich nicht welcher Wert hier gut wäre, aber es sollte auch mit 1280er Breit noch passen.

(http://upload.beyondhollywood.de/images/1376050692_2013-08-09_14_03_05-Antworten.jpg)

(http://upload.beyondhollywood.de/images/1376050692_2013-08-09_14_15_462-Antworten.jpg)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 10. August 2013, 16:25:57
Hey Andi,

ich habe noch folgendes Problem. Tritt mit IE auf.

(http://upload.beyondhollywood.de/images/1376049842_2013-08-09_14_03_05-Antworten.jpg)


Sieht bei Chrome bei mir am Rechner genau so aus:

(http://upload.beyondhollywood.de/images/1376144722_whoops.jpg)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 10. August 2013, 21:21:10
Chrome benutze ich ja selbst, im hellen Theme ist damit alles einwandfrei. Das wäre dann noch ein Unterschied zwischen hell/dunkel.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 12. August 2013, 13:26:30
Die Smilies sind wieder die alten, keine ungewohnten Fremdlinge mehr dabei.

Ich fasse mal kurz zusammen, was noch an Problemen/Änderungen ansteht.

- Texteingabefelder in speziellen Fällen noch zu klein oder zu groß, Problem hauptsächlich durch den IE verursacht. Wie immer.

- Am Theme bzw. den Themes will ich noch ein wenig basteln. Das wird allerdings eine größere Sache und noch länger dauern. Ich möchte im Grunde ein neues, zusätzliches Theme gestalten, welches für mobile Endgeräte spezialisiert ist. Es wird Zeit für etwas modernes, Smartphone-taugliches.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Flightcrank am 14. August 2013, 15:29:16
Zitat
- Texteingabefelder in speziellen Fällen noch zu klein oder zu groß, Problem hauptsächlich durch den IE verursacht. Wie immer.
Das Problem (wie Greg gepostst hat) habe ich auch noch im IE. Normalerweise nutze ich privat ausschließlich Firefox aber im Büro ist nur der IE erlaubt und daher ist es mir aufgefallen. Wäre cool wenn das demnächst  noch behoben wird.  :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 14. August 2013, 17:30:42
Ich wiederhole mich zwar, aber wie gesagt, sagt mir eine Breite die ich eingeben soll, dann mache ich das. Ich warte nur auf Input der wenigen IE User, da ich es nicht selbst bestimmen möchte, weil ich es nicht nutze.

Problem: Die eigentlich korrekte Breite des Eingabefeldes (ausgerichtet an der Fensterbreite) wird durch CSS vorgegeben. Deswegen habe ich die "Cols"-Breite der Textarea auf 0 gesetzt - so halten sich alle Browser bis auf den fucking IE an die durch CSS festgelegte Wunschbreite, die sich korrekt dem Fenster anpasst.

Ich muss für den IE wohl eine feste Spaltenzahl als Breite vorgeben. Die ignoriert dann aber vollkommen die Fenstergröße. Müssen uns also auf eine Breite einigen/festlegen, die für alle möglichen Fenstergrößen einigermaßen passt. 80 Zeichen Breite könnten für einige Konfigurationen schon zu viel sein, ist für ein großes Fenster schon zu schmal. Was schlägst du als Breite vor?

Was die Breit angeht weiß ich nicht welcher Wert hier gut wäre, aber es sollte auch mit 1280er Breit noch passen.

So wie das ganze aufgebaut ist läuft es ohne größere Änderungen (die ich zumindest zur Zeit nicht machen kann) leider nur so, dass ich dem IE eine feste Breite für das Fenster vorgeben muss, und zwar in Spalten. Also beispielsweise 80 Zeichen, 50 Zeichen, 150 Zeichen, whatever. Sagt mir, was ihr euch wünscht. Das, was ihr aktuell seht, scheint das Minimum zu sein.

Ich kenne das Verhalten der verschiedenen IE-Versionen hier einfach nicht genau genug, um auf eine andere Lösung zu kommen. Wenn irgend ein IE-Spezialist das besser weiß, möge er sich bitte melden und mir die Lösung sagen. :) Ich will gar nicht erst daran denken, wie sich der mobile IE auf Windows Phones verhält. Das kommt noch dazu.

Ich meine, irgendwas muss sich zwischen den SMF-Versionen 2.0 RC 4 und 2.0.5 natürlich geändert haben, wenn der IE nun so rumzickt. Vor dem Update hat sich zumindest keiner beschwert, da schien es also noch überall gepasst zu haben. Ich bin jedoch bisher nicht dahinter gestiegen und mit meinem Latein am Ende. Außer dieser festen Lösung fällt mir zur Zeit nichts ein. Der "Bug" scheint auch dort bekannt zu sein, sieht mir jedoch nicht danach aus, als würde es dort in nächster Zeit behoben.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 19. August 2013, 22:23:45
Ich wiederhole mich zwar, aber wie gesagt, sagt mir eine Breite die ich eingeben soll, dann mache ich das. Ich warte nur auf Input der wenigen IE User, da ich es nicht selbst bestimmen möchte, weil ich es nicht nutze.

Problem: Die eigentlich korrekte Breite des Eingabefeldes (ausgerichtet an der Fensterbreite) wird durch CSS vorgegeben. Deswegen habe ich die "Cols"-Breite der Textarea auf 0 gesetzt - so halten sich alle Browser bis auf den fucking IE an die durch CSS festgelegte Wunschbreite, die sich korrekt dem Fenster anpasst.

Ich muss für den IE wohl eine feste Spaltenzahl als Breite vorgeben. Die ignoriert dann aber vollkommen die Fenstergröße. Müssen uns also auf eine Breite einigen/festlegen, die für alle möglichen Fenstergrößen einigermaßen passt. 80 Zeichen Breite könnten für einige Konfigurationen schon zu viel sein, ist für ein großes Fenster schon zu schmal. Was schlägst du als Breite vor?

Was die Breit angeht weiß ich nicht welcher Wert hier gut wäre, aber es sollte auch mit 1280er Breit noch passen.

So wie das ganze aufgebaut ist läuft es ohne größere Änderungen (die ich zumindest zur Zeit nicht machen kann) leider nur so, dass ich dem IE eine feste Breite für das Fenster vorgeben muss, und zwar in Spalten. Also beispielsweise 80 Zeichen, 50 Zeichen, 150 Zeichen, whatever. Sagt mir, was ihr euch wünscht. Das, was ihr aktuell seht, scheint das Minimum zu sein.

Wie gesagt, unter Chrome sieht es (zumindest bei mir) immer noch so aus:

(http://upload.beyondhollywood.de/images/1376943712_argh.jpg)

Ist gerade sehr unpraktisch. Hab gerade Bock, ein paar Reviews zu schreiben, und ich seh so oft nicht die Zeilenumbrüche etc. und muss ständig auf Vorschau klicken, um sicher zu gehen, dass alles passt, die Links komplett sind etc.


btw auch noch mal danke für die ganze bisherige Arbeit, Andi  :thumb:


P.S.: Auf dem Smartphone ist das Eingabefeld "normal".
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 19. August 2013, 22:42:35
Wie gesagt, unter Chrome sieht es (zumindest bei mir) immer noch so aus:

...

Ist gerade sehr unpraktisch. Hab gerade Bock, ein paar Reviews zu schreiben, und ich seh so oft nicht die Zeilenumbrüche etc. und muss ständig auf Vorschau klicken, um sicher zu gehen, dass alles passt, die Links komplett sind etc.

btw auch noch mal danke für die ganze bisherige Arbeit, Andi  :thumb:

Ich vermute da liegt irgend ein Cacheproblem oder sowas bei dir, weil es bei mir mit Chrome geht. Versuche mal von Hand, die CSS Files neu zu laden und sowas, dann müsste es eigentlich gehen. Schlimmstenfalls mal Browsercache ganz löschen. Wenn das alles nicht helfen sollte ist es ein versteckter Bug, der im dunklen Theme noch irgendwo steckt. Da hab ich auf die Schnelle aber nix mehr gefunden. Könntest dann einfach auf das helle Theme umschalten, da MUSS Chrome gehen.

Als schnellen Workaround kannst du auch einfach die Schnellantwort verwenden. Mit Chrome kannst du die zumindest an der unteren rechten Ecke anpacken und auf beliebige Größe ziehen, dann kannst du die bis auf volle Bildschirmhöhe vergrößern wenn du willst.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Flightcrank am 22. August 2013, 13:28:10
Andi, stell mal für den IE bitte irgendwas größeres ein. Was brauchst Du für eine Angabe? Pixel? Cm? Ich weiss es ja selbst nicht...
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 23. August 2013, 07:20:34
Zitat von: Bloodsurfer
in Spalten. Also beispielsweise 80 Zeichen, 50 Zeichen, 150 Zeichen

Spalten -> Buchstaben. Zahl zwischen 80 und beliebig viel.
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Flightcrank am 23. August 2013, 08:47:16
Zitat von: Bloodsurfer
in Spalten. Also beispielsweise 80 Zeichen, 50 Zeichen, 150 Zeichen

Spalten -> Buchstaben. Zahl zwischen 80 und beliebig viel.
Okay, wer lesen kann ist klar im Vorteil! ;) :D

Dann mach doch mal 120. Ich gebe Feedback wie das bei mir im Büro (23" Monitor) aussieht. :)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Sing-Lung am 23. August 2013, 09:19:08
Ich nutze hier im Büro auch den IE, da habe ich keine Probleme!

Allerdings habe ich bewusst nicht den IE 9! ;)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 24. August 2013, 12:24:26
Dann mach doch mal 120. Ich gebe Feedback wie das bei mir im Büro (23" Monitor) aussieht. :)

120 sind jetzt eingestellt.

Pierre und andere Chrome-User, euch wollte ich noch was sagen...

Als schnellen Workaround kannst du auch einfach die Schnellantwort verwenden. Mit Chrome kannst du die zumindest an der unteren rechten Ecke anpacken und auf beliebige Größe ziehen, dann kannst du die bis auf volle Bildschirmhöhe vergrößern wenn du willst.

Dieses Feature von Chrome funktioniert natürlich nicht nur bei der Schnellantwort, sondern in jeder Textarea, also in jedem mehrzeiligen Texteingabefeld. Das habe ich ganz vergessen. Ihr könnt das zu kleine "Antwort"-Feld, falls dessen Größe immer noch nicht passen sollte, wie jede Textarea einfach auf eine beliebige Größe ziehen.

In der rechten unteren Ecke dieser Textarea sieht man so zwei kleine Linien. Wenn du genau dort in diese Ecke hinein klickst, kannst du das Feld auf beliebige Größe ziehen. Siehe den roten Pfeil in folgendem Screenshot:

(http://upload.beyondhollywood.de/images/1377339805_vorher.PNG)

Und voilà!

(http://upload.beyondhollywood.de/images/1377339805_nachher.PNG)
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Flightcrank am 26. August 2013, 12:16:18
Dann mach doch mal 120. Ich gebe Feedback wie das bei mir im Büro (23" Monitor) aussieht. :)

120 sind jetzt eingestellt.
Sieht bei mir im Büro astrein aus! Danke! :thumb:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: nemesis am 26. August 2013, 14:37:53
Danke, passt wieder.  :biggrin:
Titel: Antw:ACHTUNG: Server-Auszeit in den nächsten Tagen!
Beitrag von: Bloodsurfer am 26. August 2013, 20:23:55
Macht mal beide bitte noch Screenshots zum Vergleich ;)